summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control18
-rw-r--r--debian/copyright2
-rw-r--r--debian/fswarn.postinst18
-rw-r--r--debian/fswarn.postrm15
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
8 files changed, 65 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..4bd9095
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+fswarn (0.1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Joe Rayhawk <jrayhawk@omgwallhack.org> Sat, 08 Sep 2012 11:01:59 -0700
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..06e1e6a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,18 @@
+Source: fswarn
+Maintainer: Joe Rayhawk <jrayhawk@omgwallhack.org>
+Section: admin
+Build-depends: debhelper (>= 7)
+Priority: extra
+Homepage: http://piny.be/fswarn/
+Standards-version: 3.9.1
+
+Package: fswarn
+Architecture: all
+Depends: ${misc:Depends}
+Recommends: mail-transport-agent, cron
+Description: cron.hourly filesystem utilization check
+ Prints warnings of utilization of total blocks or inodes over a configurable
+ percentage threshold.
+ .
+ fswarn relies on the MAILTO function of cron. An MTA should probably be
+ present and operational for this to do anything useful.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f626d21
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,2 @@
+Copyright © 2010 Joe Rayhawk <jrayhawk@omgwallhack.org>
+Licensed under the BSD 3-clause license.
diff --git a/debian/fswarn.postinst b/debian/fswarn.postinst
new file mode 100644
index 0000000..3e859e2
--- /dev/null
+++ b/debian/fswarn.postinst
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+set -e
+
+case "$1" in
+
+ configure)
+
+ if [ "$2" = "" ]; then
+ mkdir /var/lib/fswarn || true
+ fi
+
+ ;;
+
+ *)
+ ;;
+
+esac
diff --git a/debian/fswarn.postrm b/debian/fswarn.postrm
new file mode 100644
index 0000000..1c31ccd
--- /dev/null
+++ b/debian/fswarn.postrm
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+set -e
+
+case "$1" in
+
+ purge)
+ rm -r /var/lib/fswarn/ || true
+ ;;
+
+ *)
+ ;;
+
+esac
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2d33f6a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)