summaryrefslogtreecommitdiff
path: root/libpiny/Build.PL
diff options
context:
space:
mode:
authorJoe Rayhawk <jrayhawk@richardiv.omgwallhack.org>2010-10-30 07:31:35 -0700
committerJoe Rayhawk <jrayhawk@richardiv.omgwallhack.org>2010-10-30 07:31:35 -0700
commitc952a7e6d5e66e2ecd653bb5c177609b59619808 (patch)
treed2be5d0dee505ae00c4b85a5f4129efc2456d5f6 /libpiny/Build.PL
parentd03e1eb495c79c19dc70bbe8eab81eadce98210a (diff)
parent79c284badd015f88d8fd42d941e30bca70dd4eb9 (diff)
downloadpiny-code-c952a7e6d5e66e2ecd653bb5c177609b59619808.tar.gz
piny-code-c952a7e6d5e66e2ecd653bb5c177609b59619808.zip
Merge branch 'master' of piny.be:/srv/git/piny-code
Diffstat (limited to 'libpiny/Build.PL')
-rw-r--r--libpiny/Build.PL30
1 files changed, 30 insertions, 0 deletions
diff --git a/libpiny/Build.PL b/libpiny/Build.PL
new file mode 100644
index 0000000..bfb5fd7
--- /dev/null
+++ b/libpiny/Build.PL
@@ -0,0 +1,30 @@
+use Module::Build;
+
+open( DCH, "<", "debian/changelog" ) or die "changelog: $!";
+
+my $version = "0";
+while ( defined ( my $line = <DCH> ) ) {
+ if ( $line =~ /\(([0-9.]+)\)/ ) {
+ $version = $1;
+ last;
+ };
+};
+
+close( DCH );
+
+my $build = Module::Build->new
+ ( 'module_name' => 'Piny'
+ , 'dist_version' => $version
+ , 'license' => 'BSD-3'
+ , 'setup_files' => { 'share/ikiwiki.setup' => 'share/ikiwiki.setup' }
+ , 'install_path' =>
+ { 'share' => '/usr/share/libpiny'
+ }
+ , 'requires' =>
+ { 'Moose' => 0
+ , 'Email::Valid::Loose' => 0
+ }
+ );
+
+$build->add_build_element( "setup" );
+$build->create_build_script( );