diff options
author | Bryan Bishop <kanzure@gmail.com> | 2015-06-08 08:04:38 -0500 |
---|---|---|
committer | Bryan Bishop <kanzure@gmail.com> | 2015-06-08 08:04:38 -0500 |
commit | dab279a7029b7376f8b083c30719d4775bc584a6 (patch) | |
tree | 80e4bedb5ef3ca1fb7f58f608d8cd80c41365b94 /setup.py | |
parent | 2ab2ffba1d52f7015de0bbc444fae7d07c5eff69 (diff) | |
download | rpcblockchainexplorer-dab279a7029b7376f8b083c30719d4775bc584a6.tar.gz rpcblockchainexplorer-dab279a7029b7376f8b083c30719d4775bc584a6.zip |
fix setup.py things
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1,13 +1,14 @@ # coding: utf-8 import os +import re try: from setuptools import setup except ImportError: from distutils.core import setup -base_path = os.path.dirname(__FILE__) +base_path = os.path.dirname(__file__) requirements_path = os.path.join(base_path, "requirements.txt") long_description_path = os.path.join(base_path, "README.md") version_path = os.path.join(base_path, "rpcblockchainexplorer/__init__.py") @@ -22,7 +23,7 @@ def __filter_requirements(requirements): """ Remove lines that are not related to requirements. """ - return [line for line in requirements if line[0] != "#"] + return [line for line in requirements if len(line) > 0 and line[0] != "#"] def __get_version(version_content): """ |